5209R: CentOS 7.8 updates

Posted by: mstauber Category: General

CentOS 7.8 updates have been released.

Last night the CentOS project released updates that bring CentOS 7 to version 7.8. Within these updates was a new ImageMagick, which caused problems with our PHP add-on PKGs from the shop.

We're quite surprised that RedHat/CentOS chose to make a drastic version number bump for ImageMagick, which deprecated libraries and Symlinks. That always rocks the boat and in this case it affected our PHP builds.

So we just published an updated base-vsite that now requires "solarspeed-ImageMagick-compat" which restores compatibility between the current PHP builds and ImageMagick. You'll either automatically get this during the next YUM update, or it will be installed alongside the CentOS 7.8 updates if you don't have them yet. To be sure you can also run "yum clean all" and "yum update" manually.

All future PHP PKGs delivered via NewLinQ will of course be built against the latest OS supplied ImageMagick.


Return
General
Apr 28, 2020 Category: General Posted by: mstauber
Previous page: Home Next page: API Documentation